RICHMODS

Here you can talk about the joy owning a Volvo 480 brings. Non-technical discussions take place here, like what is the difference between an ES and a S version.

Moderators: jifflemon, coyote1980, Rachel

User avatar
lee
480 Is my middle name
Posts: 1673
Joined: Thu Jan 23, 2003 8:24 pm
Location: Sheffield, uk

Post by lee » Sun Jun 28, 2009 8:27 am

All those that have paid have had their mods done yesterday.
pa.chab Posted: Sat Jun 27, 2009 8:54 pm Post subject:

Problems with my bank and paypal, and my parents don't want to help me with "this fucking car"...

Lee you can sell my orange ECU to some one else

sorry
As with all previous messages those ECU's not paid for will not get done. Your standard Orange ecu is here. For me to return your ecu it will £20 which will needs to be paid within 2 weeks or you will loose the ECU. This was the arrangment which everyone agreed to.
hmmmmmmmmmmmmmmm

User avatar
pa.chab
Started learning about 480
Posts: 54
Joined: Mon May 26, 2008 9:28 pm

Post by pa.chab » Sun Jun 28, 2009 8:57 am

I know Lee, and I agreed with the arrangement. :wink:
[img]http://i112.photobucket.com/albums/n184/pachab/volvobx1.gif[/img]

richj
Knows where Volvo is from
Posts: 180
Joined: Wed May 14, 2008 1:51 pm

Post by richj » Tue Jun 30, 2009 12:37 pm

I received my ecu this afternoon :)

Got it fitted after fighting the air hose thing.

It is mental!

From around 3k rpm up you can really feel the acceleration pulling you back.

Thank you Lee

Great Job!

User avatar
lee
480 Is my middle name
Posts: 1673
Joined: Thu Jan 23, 2003 8:24 pm
Location: Sheffield, uk

Post by lee » Tue Jun 30, 2009 6:12 pm

well to the mod club

glad you got it and are pleased with your purchase
hmmmmmmmmmmmmmmm

richj
Knows where Volvo is from
Posts: 180
Joined: Wed May 14, 2008 1:51 pm

Post by richj » Tue Jun 30, 2009 7:27 pm

thankyou :)

I did a quick video to check what the performance was like. Seems late 6's to early 7's for 0-60 :)

http://www.youtube.com/watch?v=aDLHE9I4rIE

fox313
480 Newbie
Posts: 23
Joined: Wed May 27, 2009 6:37 am

Post by fox313 » Tue Jun 30, 2009 8:25 pm

i have t25turbo, how it will be??? hmmm :kill:

next monday will test ;)
Last edited by fox313 on Wed Jul 08, 2009 8:06 am, edited 1 time in total.
Volvo turbo

reevio
Started learning about 480
Posts: 54
Joined: Thu Feb 19, 2009 5:11 pm
Location: oxford uk

Post by reevio » Sun Jul 05, 2009 8:07 pm

slapped mine back in the clio and its noticable straight away 0-60 easily 6 seconds as mines tottaly stripped to and weights not alot anyway cheers lee and rich im very happy
volvo v40 t4 2001 daily 210bhp
volvo 480 turbo lump in my clio valver bhp?

fox313
480 Newbie
Posts: 23
Joined: Wed May 27, 2009 6:37 am

Post by fox313 » Sun Jul 05, 2009 9:23 pm

for the present my ecu has not come yet.. waiting for Tuesday. ;)
Volvo turbo

Grapee
480 Newbie
Posts: 13
Joined: Tue May 19, 2009 1:57 pm
Location: Budapest, Hungary
Contact:

Post by Grapee » Mon Jul 06, 2009 7:59 pm

Hi All!

We got our ECUs back - big Thanks to Lee and Rich!!!

Just one Question: (I tried mine as fast as i could exchange it with the original one :))

It seems to me, that the Pressure is building up very slowly...is this normal (slow reacting T2?)? I have to rev past 4000, to get the needle on the Turbo gauge beyond the factory max. charge point (go over 0,45 bar).
Couldn't try a 0-60 - too much traffic around, but shouldn't it build up the full pressure somewhere around 3000 - as it does with stock ECU?

I also opened the ECU, just to have a look :D I could see a resistor soldiered between the MAP sensor resistor and a chip - but no change in any of the ICs - is this normal? (Think so... :D)

It's just a bunch of questions, please don't missunderstand it!!

fox313
480 Newbie
Posts: 23
Joined: Wed May 27, 2009 6:37 am

Post by fox313 » Wed Jul 08, 2009 8:03 am

i get my ecu, but my car doesnt start.
i tried to call to lee, but he doesnt answer.

it seems like no ecu plugged in. no reaction. :cryhard:
Volvo turbo

User avatar
glasgowjim
480 Is my middle name
Posts: 4827
Joined: Sun Oct 01, 2006 5:28 pm
Location: GLASGOW SCOTLAND

Post by glasgowjim » Wed Jul 08, 2009 9:45 am

fox313 Lee is very busy he works all hours frequently away from home he will get back to you but it can take a little bit of time.

richj
Knows where Volvo is from
Posts: 180
Joined: Wed May 14, 2008 1:51 pm

Post by richj » Wed Jul 08, 2009 1:03 pm

I have to rev past 4000, to get the needle on the Turbo gauge beyond the factory max. charge point (go over 0,45 bar).

Mine is the same. I think I read somewhere that rich designed the mod to start with 3/4 throttle. So with less than 3/4 throttle it is boosting to the factory level, and with more the mod kicks in and gives you the extra boost.

I'm not sure this is ideal for 1/4 mile drag racing, but it seems to be working very nicely for daily driving.

fox313
480 Newbie
Posts: 23
Joined: Wed May 27, 2009 6:37 am

Post by fox313 » Wed Jul 08, 2009 7:03 pm

glasgowjim wrote:fox313 Lee is very busy he works all hours frequently away from home he will get back to you but it can take a little bit of time.
oke, but it is not funny, i have no car about one month.
Volvo turbo

User avatar
dragon
Volvo 480 Club Europe CREW
Posts: 3705
Joined: Mon Nov 18, 2002 5:33 pm
Location: South Yorkshire, UK
Contact:

Post by dragon » Wed Jul 08, 2009 9:51 pm

richj wrote:
I have to rev past 4000, to get the needle on the Turbo gauge beyond the factory max. charge point (go over 0,45 bar).

Mine is the same. I think I read somewhere that rich designed the mod to start with 3/4 throttle. So with less than 3/4 throttle it is boosting to the factory level, and with more the mod kicks in and gives you the extra boost.

I'm not sure this is ideal for 1/4 mile drag racing, but it seems to be working very nicely for daily driving.
Yes, having to practically floor it to get the Richmod boosting fully is a feature of the mod.

Don't worry though, as my V70 also needs to be "foot to the floor" to activate it's full boost with my new turbo on too, so is a "feature" of bigger boost on Volvos lol. Haven't used my new 480 Richmod yet, as waiting for a wiring loom, so we had to do something to the V70 in the meantime lol!

The V70 is now producing 20PSI (1.4bar) pressure on LPG and was seen nicely racing a brand new Mitsubishi Evo (we think F320) last weekend, and well... I think the owner was upset... And that was with a bloody huge and heavy TV in the back. Mind you a certain other T5 wasn't so far behind either, and he had a freezer in the boot! lol

Oh yes, we officially eat Skoda Octavia VRSs for breakfast too ;)
Cheers! [img]http://www.dragons.org.uk/images/guin.gif[/img]

Gaz Wilson


1997 V70R AWD in Saffron, RICA 580, hot hot HOT!
1995 480 Turbo, Flame Red Metallic/Jacquard-Leather
1993 480 turbo, Vase Green Metallic/Jacquard-Leather
1995 Range Rover 4.6 HSE V8 - Full leather and more!
http://volvo480.northernscum.org.uk <--- Full spec!

Got horses? - [url=http://www.horse-teeth.co.uk][img]http://www.northernscum.org.uk/avatars/ggedt_anim.gif[/img][/url]

Grapee
480 Newbie
Posts: 13
Joined: Tue May 19, 2009 1:57 pm
Location: Budapest, Hungary
Contact:

Post by Grapee » Thu Jul 09, 2009 7:08 am

Ok, then this is a feature, not a bug :)

...and a very good one: no need for extra power -> no wasted fuel :)

It's just all new to me, so i have to learn, how to use it 8)
Thank you for the infos.

And certainly again great thanks to Rich and Lee!! 8)

reevio
Started learning about 480
Posts: 54
Joined: Thu Feb 19, 2009 5:11 pm
Location: oxford uk

Post by reevio » Thu Jul 09, 2009 7:56 pm

dragon wrote:
Oh yes, we officially eat Skoda Octavia VRSs for breakfast too ;)
yes my clio often does this im very happy with the mod im taking it to santa pod nxt month so il get some results up also on the dyno tosee what its pushing out
volvo v40 t4 2001 daily 210bhp
volvo 480 turbo lump in my clio valver bhp?

DaKyy
480 Is my middle name
Posts: 919
Joined: Sat Sep 20, 2003 5:13 pm
Location: Paimio, Finland

Post by DaKyy » Fri Jul 10, 2009 7:04 pm

Just out of curiosity, how can I tell what ecu I have as my box on the centre console (with the vacuum pipe) had only one sticker on it - the white one with some text. No orange or red sticker.
[url=http://picasaweb.google.co.uk/ahti.peura/Volvo480ES1987RestorationProject#][img]http://www.ihku.org/~dakyy/signature.jpg[/img][/url]

User avatar
lee
480 Is my middle name
Posts: 1673
Joined: Thu Jan 23, 2003 8:24 pm
Location: Sheffield, uk

Post by lee » Sat Jul 11, 2009 9:42 am

the richmod has had a different map loaded as well as other things

for max boost you need to have your foot flat down. boost is also limited in first and second.
fox313 Posted: Wed Jul 08, 2009 9:03 am Post subject:

i get my ecu, but my car doesnt start.
i tried to call to lee, but he doesnt answer.

it seems like no ecu plugged in. no reaction.
contacted
hmmmmmmmmmmmmmmm

fox313
480 Newbie
Posts: 23
Joined: Wed May 27, 2009 6:37 am

Post by fox313 » Thu Jul 30, 2009 8:48 pm

lee wrote:the richmod has had a different map loaded as well as other things

for max boost you need to have your foot flat down. boost is also limited in first and second.
fox313 Posted: Wed Jul 08, 2009 9:03 am Post subject:

i get my ecu, but my car doesnt start.
i tried to call to lee, but he doesnt answer.

it seems like no ecu plugged in. no reaction.
contacted
uce is back. all ok ;) thx
Volvo turbo

Grapee
480 Newbie
Posts: 13
Joined: Tue May 19, 2009 1:57 pm
Location: Budapest, Hungary
Contact:

Post by Grapee » Thu Aug 27, 2009 8:17 am

Hi All!

Anybody seen Lee?

It's getting urgent to fix the last ECU with wrong SW on it.

Please Lee, if you read this, drop me a PM!!

Thnx!

Post Reply