Loud noise on switch on

Here you can post things about ICE (In Car Entertainment). Like how to install GPS navigation, a DVD-player and other yuppie-stuff. This category might be moved to "those other things" in the end...

Moderators: jifflemon, coyote1980, Rachel

Post Reply
Jetronic63
480 Newbie
Posts: 3
Joined: Sun Sep 10, 2017 3:48 pm

Loud noise on switch on

Post by Jetronic63 » Tue Sep 12, 2017 9:28 am

Hello, newby here trying to sort out the issues with my recently bought 480. The stereo (original I think) makes a loud 'crack' through the speakers when its turned on. It makes me wince and it cant be good for the speakers - seems to work fine after that although I notice the cassette door is missing so it might have had some 'attention' in the past. Any thoughts on cause of the noise and/or what to check out ?

Thanks

frenchfries
Advanced 480 rookie
Posts: 561
Joined: Thu Apr 06, 2017 8:11 pm

Re: Loud noise on switch on

Post by frenchfries » Tue Sep 12, 2017 10:35 am

Sounds like the noise an old radio makes when you turn the volume up or down.

I Was always told it was because of this:
https://en.m.wikipedia.org/wiki/Potentiometer
1993 Turbo auto called Skip for the important stuff
2011 Juke 190 for everything else

Robou
Knows an Aerodeck isn't a 480
Posts: 269
Joined: Sun Jul 08, 2007 11:34 pm

Re: Loud noise on switch on

Post by Robou » Tue Sep 12, 2017 12:30 pm

If the "crack" is only there when the radio is turned on as you claim it may be because the endstage of the amplifier carries a direct voltage which makes the speakercone(s) move in or out and stay in that position. This heats up the speakercoil and will eventualy ruin the speaker, if not cause further damage to the endstage. Remove the cover and check if the cone permanently changes position when the radio is switched on.

If it is a cracking sound while activating the volume control this is caused by intermittent contact between the wiper and the resitance material. The only remedy, apart from renewing the control, is turning the control back and forth al the way several times. Unfortunetly the control also switches the radio on. When power is controlled by the ignition switch turn it off, if not find a way to unpower the radio. This solution will have to be repeated in time.
Too old to bother
480 Turbo midst '91

Jetronic63
480 Newbie
Posts: 3
Joined: Sun Sep 10, 2017 3:48 pm

Re: Loud noise on switch on

Post by Jetronic63 » Tue Sep 12, 2017 8:50 pm

Thanks, speakers seem to be in the normal position after switch on. The unit only makes this 'crack' sound when you switch it on, after that it works fine with no other random noises. I had the same problem in my 760 and happened to have a spare amp, swapped the amps and the sound disappeared. Perhaps a characteristic of the amp ageing ? Could look for a replacement or just change the head unit, quite like the OE look though.

Robou
Knows an Aerodeck isn't a 480
Posts: 269
Joined: Sun Jul 08, 2007 11:34 pm

Re: Loud noise on switch on

Post by Robou » Wed Sep 13, 2017 8:15 pm

At power on amplfiers can be unstable for a short moment and produce a noise, this is by design. It can be avoided at a cost, sometimes it is solved by activating a relay which connects the speakers a few moments after power on and immediatly after power off. When the speakers stay in position there is no reason to worry, a false alarm I would say.
Too old to bother
480 Turbo midst '91

Jetronic63
480 Newbie
Posts: 3
Joined: Sun Sep 10, 2017 3:48 pm

Re: Loud noise on switch on

Post by Jetronic63 » Wed Sep 13, 2017 9:02 pm

Thanks, that's reassuring.

Post Reply