*** Problems with Volvo CR-901 radio***

Here you can post things about ICE (In Car Entertainment). Like how to install GPS navigation, a DVD-player and other yuppie-stuff. This category might be moved to "those other things" in the end...

Moderators: jifflemon, coyote1980, Rachel

Post Reply
il Conte
Knows where Volvo is from
Posts: 106
Joined: Sat Sep 09, 2006 8:41 am
Location: Roma

*** Problems with Volvo CR-901 radio***

Post by il Conte » Sun Jan 10, 2010 10:34 pm

Hi guys!
Few days ago I bought a CR901 radio with Amp and CD401 controller.

I removed my stereo and I restored the original wiring to connect the new purchase. Unfortunately I have some problem, I hope you can help me...

1) Does not illuminate any of the main lights of the stereo (I opened the stereo but the lights I tested are working) but the lights of the buttons works fine!

2) the audio output on the driver side is very feeble, while on the passenger side works very well!
I tried to balance the audio output but the result is not changed: If I exclude the audio output on the passenger side feels little or nothing; If I balance the audio output centrally feels good on the passenger side and a little bit on the driver side. :(

3) I also bought an amplifier (I think 4x20W) but I don't know how to connect it properly on the radio!
Now I can connect it to the radio through a cable with 6 pin but I don't know how to connect the rear speakers and where I could find the wiring for the power.

Tomorrow I will post the photos of the radio and wiring.

Someone could help me??

Thank you!

User avatar
glasgowjim
480 Is my middle name
Posts: 4828
Joined: Sun Oct 01, 2006 5:28 pm
Location: GLASGOW SCOTLAND

Post by glasgowjim » Sun Jan 10, 2010 10:41 pm


Post Reply