Immobiliser & central locking problems - unable to start car

From CEM to VEM, from LED to lightbulb and more. If you have an electrical problem, like a broken info-centre, search for answers in this category. This is also the place to be when you expect the problem to be of an electrical nature...

Moderators: jifflemon, coyote1980, Rachel

Post Reply
User avatar
89of480
Knows where Volvo is from
Posts: 136
Joined: Fri Aug 28, 2015 2:36 pm
Location: Trying to get the A/C to work
Contact:

Immobiliser & central locking problems - unable to start car

Post by 89of480 » Sun May 20, 2018 5:29 pm

So I got the car all MOT’d yesterday and everything (more on this later), but since yesterday (despite nothing changing) I’ve been having issues with the immobiliser not working, or rather working, and leaving me unable to start the car. There seems to be an intermittent problem with the driver’s door lock, when turning it with the key, it doesn’t actually power open; it just unlocks and therefore does not power open the passenger door, the LED will either remain solid on, or will flash until I put the key in the ignition and then go solid on, leaving me unable to start the car. Sometimes the driver’s door will power open and open the passenger door, other times the passenger door will power open after opening the driver’s door. I ended up getting stranded at a petrol garage right before my MOT and had to wait for my dad to come to the rescue with a spanner to disconnect the battery! I found a couple of bolts loose in the side of the door that hold the latch in place, I tightened these up and a couple of times after this the doors powered open fine, I thought this had solved the issue but now I’m still having troubles with it, completely out of nowhere. Can anyone help point me in the right direction for this? Thanks :D
‘95 Celebration Auto - №89 of 480 - Flame Red Metaillic
‘17 BMW M140i Shadow Edition - Black Sapphire Metallic

User avatar
89of480
Knows where Volvo is from
Posts: 136
Joined: Fri Aug 28, 2015 2:36 pm
Location: Trying to get the A/C to work
Contact:

Re: Immobiliser & central locking problems - unable to start car

Post by 89of480 » Thu May 31, 2018 11:48 pm

Sorry to ‘bump’ this again guys, but my mind has been stirring away here, is it possible the driver’s door solenoid/unit could be the culprit here? It would mean a lot to me if someone could help me out with this :D I dont want to end up stranded somewhere! :lol:
Thanks guys! You’re the best! :wink:
‘95 Celebration Auto - №89 of 480 - Flame Red Metaillic
‘17 BMW M140i Shadow Edition - Black Sapphire Metallic

User avatar
AleksanderHugo
480 Newbie
Posts: 49
Joined: Wed Aug 24, 2016 7:13 pm
Location: Lodz, Poland

Re: Immobiliser & central locking problems - unable to start car

Post by AleksanderHugo » Fri Jun 01, 2018 8:55 am

I would start by getting to the microswitches by the lock. Remove the plastic cover of the lock on inside of he car and see if all the meachnical parts are in place. When you turn the key a plastic “ring” presses a microswitch which sends a signal to the CEM.

If mechanical parts are ok, then check the microswitch itself, then wiring and then the CEM.

Alan 480
480 Is my middle name
Posts: 918
Joined: Sun Aug 28, 2011 9:03 am
Location: Aberdeen

Re: Immobiliser & central locking problems - unable to start car

Post by Alan 480 » Fri Jun 01, 2018 11:34 am

AleksanderHugo wrote:
Fri Jun 01, 2018 8:55 am
I would start by getting to the microswitches by the lock. Remove the plastic cover of the lock on inside of he car and see if all the meachnical parts are in place. When you turn the key a plastic “ring” presses a microswitch which sends a signal to the CEM.

If mechanical parts are ok, then check the microswitch itself, then wiring and then the CEM.
sounds like a decent suggestion, I had a similar issue (in reverse) after working at the boot lock, alarm went off when closed the boot !! :?

switch was in 'wrong postion'


so could well be the issue
Alan

480 ES 2litre x 2, C30 1.8ES, SS1

User avatar
89of480
Knows where Volvo is from
Posts: 136
Joined: Fri Aug 28, 2015 2:36 pm
Location: Trying to get the A/C to work
Contact:

Re: Immobiliser & central locking problems - unable to start car

Post by 89of480 » Fri Jun 01, 2018 12:48 pm

AleksanderHugo wrote:
Fri Jun 01, 2018 8:55 am
I would start by getting to the microswitches by the lock. Remove the plastic cover of the lock on inside of he car and see if all the meachnical parts are in place. When you turn the key a plastic “ring” presses a microswitch which sends a signal to the CEM.

If mechanical parts are ok, then check the microswitch itself, then wiring and then the CEM.
Excellent! :D thanks for pointing me in the right direction, I shall report back once I’ve had a chance to look! :hopping:
Alan 480 wrote:
Fri Jun 01, 2018 11:34 am
sounds like a decent suggestion, I had a similar issue (in reverse) after working at the boot lock, alarm went off when closed the boot !! :?

switch was in 'wrong postion'


so could well be the issue
I’ve yet to hear the alarm go off! Do you need a fob for the alarm to operate though?

Thanks for your input though, I shall indeed have a nose soon!

Aah, 480 electronics...
‘95 Celebration Auto - №89 of 480 - Flame Red Metaillic
‘17 BMW M140i Shadow Edition - Black Sapphire Metallic

User avatar
89of480
Knows where Volvo is from
Posts: 136
Joined: Fri Aug 28, 2015 2:36 pm
Location: Trying to get the A/C to work
Contact:

Re: Immobiliser & central locking problems - unable to start car

Post by 89of480 » Sun Jun 03, 2018 8:26 pm

I’ve posted a couple of videos on YouTube to try and show what’s going on, just to recap;
•as of now, the passenger door (good one) will power open and disable the immobilser and turn the interior lights and let the car start
•it will also close the windows, arm the immobiliser and turn off the interior lights
•the passenger door will not lock or unlock the driver’s door (dodgy one) though
•the driver’s door will unlock, but not power open, turn on the lights or disable the immobiliser
•sometimes opening the driver’s door will unlock the passenger door (but still not disable the immobiliser)
•the driver’s door will lock the passenger door and close the windows (and arm the immobiliser and turn off the interior lights)
Anyway, here are the video links, in case they are useful? Thanks!
https://youtu.be/5cIFcPXmfe4
https://youtu.be/ezTJvrknO5w
‘95 Celebration Auto - №89 of 480 - Flame Red Metaillic
‘17 BMW M140i Shadow Edition - Black Sapphire Metallic

Alan 480
480 Is my middle name
Posts: 918
Joined: Sun Aug 28, 2011 9:03 am
Location: Aberdeen

Re: Immobiliser & central locking problems - unable to start car

Post by Alan 480 » Mon Jun 04, 2018 11:39 am

for what it's worth,

the passenger door lock will NOT unlock the driver's door on ours. there is ONLY a solenoid on the passenger door!

it does all point to an issue around the switch on the door lock, or the relay within the central module? :(
Alan

480 ES 2litre x 2, C30 1.8ES, SS1

User avatar
jamescarruthers
480 Is my middle name
Posts: 1666
Joined: Mon Jul 07, 2003 3:19 pm
Location: Cambridge

Re: Immobiliser & central locking problems - unable to start car

Post by jamescarruthers » Mon Jun 04, 2018 12:44 pm

Are you sure that you actually have an immobiliser?‎
1987 Volvo 480 ES, 507274, 217 - Red (Ness)
2001 Volvo C70 2.4T convertible (Olivolvo)
2008 Mini Cooper convertible (Mau)

Previous 480's:
J123 CFU -- ES
J449 MNL -- ES auto
D864 CPV -- ES
L691 JFC -- Turbo
F70 MNR -- ES
H858 FGV -- Turbo auto
E981 KHM -- ES (509849)

User avatar
89of480
Knows where Volvo is from
Posts: 136
Joined: Fri Aug 28, 2015 2:36 pm
Location: Trying to get the A/C to work
Contact:

Re: Immobiliser & central locking problems - unable to start car

Post by 89of480 » Mon Jun 04, 2018 1:42 pm

jamescarruthers wrote:
Mon Jun 04, 2018 12:44 pm
Are you sure that you actually have an immobiliser?‎
I am sure, if I unlock the driver’s door at the moment the LED keeps blinking and then goes solid when I turn the ignition key, and then the engine doesn’t start, but if I unlock the passenger door the LED goes out and I can start the engine fine; locking the car also makes the LED start blinking.

After the state I found the car in I’m surprised the immobiliser still works!
Alan 480 wrote:
Mon Jun 04, 2018 11:39 am
for what it's worth,

the passenger door lock will NOT unlock the driver's door on ours. there is ONLY a solenoid on the passenger door!

it does all point to an issue around the switch on the door lock, or the relay within the central module? :(
Thanks for the insight - I couldn’t remember how it was before to be fair, but that’s genuinely useful to know, thank you!

It does indeed, I shall see if I can pop the door card off later and see if I can get to the locking parts, I’ll see if I can check the switches and cover some of the connectors with some contact cleaner and go from there :D
‘95 Celebration Auto - №89 of 480 - Flame Red Metaillic
‘17 BMW M140i Shadow Edition - Black Sapphire Metallic

User avatar
89of480
Knows where Volvo is from
Posts: 136
Joined: Fri Aug 28, 2015 2:36 pm
Location: Trying to get the A/C to work
Contact:

Re: Immobiliser & central locking problems - unable to start car

Post by 89of480 » Mon Jun 04, 2018 10:43 pm

Thought I would add an update; I removed the door card and the plastic lock cover, and I used a generous amount of contact cleaner on each connector inside the door, I tried to spray some towards their direction of the micro switches along with some silicone spray for some of the mechanicals, and so far so good! The drivers door is functioning correctly again! I just hope this fix holds out!!! :wall:
‘95 Celebration Auto - №89 of 480 - Flame Red Metaillic
‘17 BMW M140i Shadow Edition - Black Sapphire Metallic

Alan 480
480 Is my middle name
Posts: 918
Joined: Sun Aug 28, 2011 9:03 am
Location: Aberdeen

Re: Immobiliser & central locking problems - unable to start car

Post by Alan 480 » Tue Jun 05, 2018 11:54 am

89of480 wrote:
Mon Jun 04, 2018 10:43 pm
Thought I would add an update; I removed the door card and the plastic lock cover, and I used a generous amount of contact cleaner on each connector inside the door, I tried to spray some towards their direction of the micro switches along with some silicone spray for some of the mechanicals, and so far so good! The drivers door is functioning correctly again! I just hope this fix holds out!!! :wall:
my type of fix :-)
Alan

480 ES 2litre x 2, C30 1.8ES, SS1

User avatar
89of480
Knows where Volvo is from
Posts: 136
Joined: Fri Aug 28, 2015 2:36 pm
Location: Trying to get the A/C to work
Contact:

Re: Immobiliser & central locking problems - unable to start car

Post by 89of480 » Wed Jun 06, 2018 11:48 am

Alan 480 wrote:
Tue Jun 05, 2018 11:54 am
89of480 wrote:
Mon Jun 04, 2018 10:43 pm
Thought I would add an update; I removed the door card and the plastic lock cover, and I used a generous amount of contact cleaner on each connector inside the door, I tried to spray some towards their direction of the micro switches along with some silicone spray for some of the mechanicals, and so far so good! The drivers door is functioning correctly again! I just hope this fix holds out!!! :wall:
my type of fix :-)
Thanks!! I will have another to later just to make sure it’s still okay! :D
‘95 Celebration Auto - №89 of 480 - Flame Red Metaillic
‘17 BMW M140i Shadow Edition - Black Sapphire Metallic

User avatar
89of480
Knows where Volvo is from
Posts: 136
Joined: Fri Aug 28, 2015 2:36 pm
Location: Trying to get the A/C to work
Contact:

Re: Immobiliser & central locking problems - unable to start car

Post by 89of480 » Wed Jun 06, 2018 11:13 pm

Unfortunately my fix was only temporary as I tried again today and no joy whatsoever :cryhard:

At least I can disable the immobiliser with the passenger door... :(
‘95 Celebration Auto - №89 of 480 - Flame Red Metaillic
‘17 BMW M140i Shadow Edition - Black Sapphire Metallic

Alan 480
480 Is my middle name
Posts: 918
Joined: Sun Aug 28, 2011 9:03 am
Location: Aberdeen

Re: Immobiliser & central locking problems - unable to start car

Post by Alan 480 » Wed Jun 20, 2018 11:55 am

so 'central-locking' but not 'central-unlocking' :-)

the old Regal also had central locking, you could reach both doors whilst seated :-)
Alan

480 ES 2litre x 2, C30 1.8ES, SS1

nigeltowner99
480 Newbie
Posts: 3
Joined: Fri Nov 23, 2018 2:32 pm

Re: Immobiliser & central locking problems - unable to start car

Post by nigeltowner99 » Fri Nov 23, 2018 2:39 pm

89of480 wrote:
Sun Jun 03, 2018 8:26 pm
I’ve posted a couple of videos on YouTube to try and show what’s going on, just to recap;
•as of now, the passenger door (good one) will power open and disable the immobilser and turn the interior lights and let the car start
•it will also close the windows, arm the immobiliser and turn off the interior lights
•the passenger door will not lock or unlock the driver’s door (dodgy one) though
•the driver’s door will unlock, but not power open, turn on the lights or disable the immobiliser
•sometimes opening the driver’s door will unlock the passenger door (but still not disable the immobiliser)
•the driver’s door will lock the passenger door and close the windows (and arm the immobiliser and turn off the interior lights)
Anyway, here are the video links, in case they are useful? Thanks!
https://youtu.be/5cIFcPXmfe4
https://youtu.be/ezTJvrknO5w
Just to say that neither of the youtube links appear to work -

Post Reply