gremlin

From CEM to VEM, from LED to lightbulb and more. If you have an electrical problem, like a broken info-centre, search for answers in this category. This is also the place to be when you expect the problem to be of an electrical nature...

Moderators: jifflemon, coyote1980, Rachel

Post Reply
User avatar
POE
Knows an Aerodeck isn't a 480
Posts: 280
Joined: Wed Dec 07, 2005 8:07 pm
Location: Hartlepool

gremlin

Post by POE » Sun Feb 14, 2016 2:52 pm

Hi ' engine stalls once coolant rad kicks in ' thought may have been battery as very week but no difference with new one ' fan turns fine by hand ' car starts fine afterwards ' noticed fan kicks in around 62 c and drops from there if engine doesn't stall or when engine stalls fan kicks in at 62 c and rises rapidly to 92 c ???

Thinking maybe alternator problem along with new thermostat ?
1989 480 turbo ,saffron pearl, half leather with richmod and full custom bodykit

Alan 480
480 Is my middle name
Posts: 1063
Joined: Sun Aug 28, 2011 9:03 am
Location: Aberdeen

Re: gremlin

Post by Alan 480 » Sun Feb 14, 2016 5:14 pm

I'd suspect a short somewhere,

doe it restart on the key, or does it need to cool down to turn teh fan off?


as a work around:-
try disconnecting the fan and watch temp if it gets toasty turn on the heaters :-)
Alan

480 ES 2litre x 2, C30 1.8ES, SS1

User avatar
POE
Knows an Aerodeck isn't a 480
Posts: 280
Joined: Wed Dec 07, 2005 8:07 pm
Location: Hartlepool

Re: gremlin

Post by POE » Mon Feb 15, 2016 8:30 pm

Will try disconnecting fan tomorrow and also noticed volts meter in car drop from 3/4 to just under half when blowers on full so not sure whether alternator is not coping with the load ? Car starts fine when fan is running just quite rough until fan stops when fine again
1989 480 turbo ,saffron pearl, half leather with richmod and full custom bodykit

Alan 480
480 Is my middle name
Posts: 1063
Joined: Sun Aug 28, 2011 9:03 am
Location: Aberdeen

Re: gremlin

Post by Alan 480 » Tue Feb 16, 2016 12:47 pm

POE wrote:Will try disconnecting fan tomorrow and also noticed volts meter in car drop from 3/4 to just under half when blowers on full so not sure whether alternator is not coping with the load ? Car starts fine when fan is running just quite rough until fan stops when fine again
does sound like an iffy alternator, or hopefully just the regulator pack, I bough a replacement off a guy for about a tenner, it was worth a try as the alternator was goosed and £10 seemed a safe bet, not much to go wrong either way

the SS1 had ONE of the diodes die which meant that voltage was only about 12V when idle and wouldn't increase with revs at 2000rpm.

on 480 it was just the regulator, helpful company on e-bay (I can find details if you need)

check voltage at battery with a voltmeter (not the one in the car :-) )
Alan

480 ES 2litre x 2, C30 1.8ES, SS1

User avatar
POE
Knows an Aerodeck isn't a 480
Posts: 280
Joined: Wed Dec 07, 2005 8:07 pm
Location: Hartlepool

Re: gremlin

Post by POE » Tue Feb 16, 2016 7:23 pm

Ok so I had car running last night for about 20mins checking various wires to no avail ' battery was disconnected last night and just done a voltage check '

14.9 v battery check not running
16.6 v car running
14.9 v under load ' heater fans on full ' hazards and heated seats
15.7 v after stopped engine and voltage was contant ???

Lion battery 52ah 460cca ?

Obviously the volts aren't in any way correct and quite high from what I've read and also noticed fan belt squeak under load only but could be nothing ' thanks for the tips and any help much appreciated
1989 480 turbo ,saffron pearl, half leather with richmod and full custom bodykit

User avatar
brinkie
480 Expert
Posts: 651
Joined: Mon Apr 21, 2014 11:20 am
Location: The Netherlands
Contact:

Re: gremlin

Post by brinkie » Tue Feb 16, 2016 9:47 pm

Whoa, 16.6V is way too high! It should not exceed 15V even under high revs without load. I think you have a problem with the voltage regulator.

The Bosch alternator has voltage regulator 1197311008, e.g. for sale new for 16,95 ex. shipping.
Paris-Rhône/Valeo either YH2925, YV1925 or YM1601. YV1925 only for Paris-Rhône alternators with 3.2 ohm rotor windings.
Robert.

Present cars: 1994 Volvo 480 GT 2.0i Vase Green, 2010 Volvo V70 2.0F Momentum Mystic Silver
Past: 1981 Talbot-Matra Murena 2.2 Rouge Mephisto, 1995 Volvo 480 GT 2.0i Paris Blue

User avatar
POE
Knows an Aerodeck isn't a 480
Posts: 280
Joined: Wed Dec 07, 2005 8:07 pm
Location: Hartlepool

Re: gremlin

Post by POE » Thu Feb 18, 2016 11:07 pm

Haha yes very high ' I have another alternator about somewhere so will swap over at weekend if I have time and post results ' and thanks for your input :D
1989 480 turbo ,saffron pearl, half leather with richmod and full custom bodykit

Alan 480
480 Is my middle name
Posts: 1063
Joined: Sun Aug 28, 2011 9:03 am
Location: Aberdeen

Re: gremlin

Post by Alan 480 » Fri Feb 19, 2016 1:12 pm

I bought bits from here in the past and pretty helpful

from memory regulator was around £10 - £12 delivered ?


http://www.jcrsupplies.co.uk/
Alan

480 ES 2litre x 2, C30 1.8ES, SS1

User avatar
POE
Knows an Aerodeck isn't a 480
Posts: 280
Joined: Wed Dec 07, 2005 8:07 pm
Location: Hartlepool

Re: gremlin

Post by POE » Sun Feb 28, 2016 10:20 pm

Haha well I found out why the engine stalls when radiator fan kicks in but first ill give you a bit of info first and see if you can guess what the problem was :lol:

Done at lot of wiring for horns etc and replaced some corroded wiring for flywheel sensor ' airbox removed and left out for the time being and still haven't refit it back so to access wiring and sort earths out for battery and aux water pump , after this work engine cuts out when rad fan cuts in ,replaced alternator and battery and checked all connections to no avail until this afternoon and could kick myself grrrrr :?
1989 480 turbo ,saffron pearl, half leather with richmod and full custom bodykit

Post Reply