Search found 47 matches

by Flying Dutchman
Mon May 18, 2015 5:55 pm
Forum: Brakes (50)
Topic: That darn ABS unit again!
Replies: 0
Views: 1025

That darn ABS unit again!

The ABS (or ABS-related thing) makes a rapid clicking sound (coming from the pedal area) all by it self, then the abs warning comes on. It happens while driving, Im not even braking when it happens. If i put my foot on the brake pedal it rattles just exactly as if I was braking on an icy road. Somet...
by Flying Dutchman
Sat Apr 04, 2015 8:07 pm
Forum: Engine (20)
Topic: Lumpy when hot
Replies: 10
Views: 2603

Re: Lumpy when hot

Hmm.. Just have to wait and see how it went for Swanny then. :)
by Flying Dutchman
Thu Apr 02, 2015 8:50 pm
Forum: Engine (20)
Topic: Lumpy when hot
Replies: 10
Views: 2603

Re: Lumpy when hot

Is this gasket replacement fix also applyable on the turbo engine?
by Flying Dutchman
Sat Mar 28, 2015 8:04 pm
Forum: Parts, Accessories & Brochures
Topic: Wanted: Rear bumper beam
Replies: 1
Views: 551

Wanted: Rear bumper beam

Doesnt have to be perfect, but repairable.
by Flying Dutchman
Wed Feb 18, 2015 8:31 pm
Forum: Engine (20)
Topic: Ticking noise from engine
Replies: 4
Views: 772

Re: Ticking noise from engine

Have got exactly the same rev dropping issue on my -90 turbo. Also jumpy idle. Especially when starting it up again with warm engine, Checked/cleaned/changed everyting I can think of. Getting pretty sure its an unfixable issue. Perhaps these engines always has been this way since new?
by Flying Dutchman
Fri Jan 16, 2015 9:18 pm
Forum: Brakes (50)
Topic: brakes loosing pressure.
Replies: 10
Views: 2835

Re: brakes loosing pressure.

Helps alot! Tells me theres something wrong with mine.. Bet there is some air left even though Ive bled them twice. ;)
Thanks! :rofl: :rofl:
by Flying Dutchman
Fri Jan 09, 2015 2:58 pm
Forum: Brakes (50)
Topic: brakes loosing pressure.
Replies: 10
Views: 2835

Re: brakes loosing pressure.

Thanks!

Did, or do you experience any sponginess in the pedal? Mine is quite soft in the upper half.

:)
by Flying Dutchman
Thu Jan 08, 2015 6:59 pm
Forum: Electrical system (30)
Topic: Rear washer pump not working
Replies: 6
Views: 1284

Re: Rear washer pump not working

glasgowjim wrote:Need a spare ? :wink: ;) ;) ;)
Thanks Jim!

I'll take a look at the scrap yard first. They often have "pocket discount" on small, rapidly removed parts. :rofl:
by Flying Dutchman
Thu Jan 08, 2015 6:54 pm
Forum: Brakes (50)
Topic: brakes loosing pressure.
Replies: 10
Views: 2835

Re: brakes loosing pressure.

This worked for you in long term? Got similar problems with mine. Exact same unit.. Mine does the fanatic "clicketyclick" when braking to often, and then the ABS lights up. Think the mian problem is leaky accumulator or main cylinder? Or both? Brakes very good, but pedal feels spongy in the upper pa...
by Flying Dutchman
Mon Jan 05, 2015 8:21 pm
Forum: Springs and Wheels (70)
Topic: Most likely to clonk?
Replies: 3
Views: 1526

Most likely to clonk?

Rear left makes clonking sounds when driving (not just in bumps). Sounds pretty near when driving (LH) Could it be the shocks? Or more likely some rubber bushings? Got a lot more quieter when I had a friend sit in the back to listen.

It is probably not the exhaust. Could not make it rattle.

cheers!
by Flying Dutchman
Fri Jan 02, 2015 7:10 pm
Forum: Engine (20)
Topic: Overheating problems!
Replies: 8
Views: 1890

Re: Overheating problems!

Finally! They installed a Volvo original thermostat and the problem vanished. No more overheating! It opens an closes perfectly, and works between 80-83 degrees. Stay the f-word away from after market junk stats! The garage is a big swedish franchaise, "Mekonomen" and have their own parts, so to spe...
by Flying Dutchman
Thu Jan 01, 2015 5:29 pm
Forum: Electrical system (30)
Topic: Rear washer pump not working
Replies: 6
Views: 1284

Re: Rear washer pump not working

Three of them? Ok. Well cant hear any sound from the bottle when pushing the little grey button.
by Flying Dutchman
Mon Dec 29, 2014 11:43 pm
Forum: Electrical system (30)
Topic: Rear washer pump not working
Replies: 6
Views: 1284

Rear washer pump not working

Is there a separate pump to the rear wiper? It has stopped spraying but I can only find one pump!?!
by Flying Dutchman
Mon Dec 29, 2014 2:53 pm
Forum: Engine (20)
Topic: Overheating problems!
Replies: 8
Views: 1890

Re: Overheating problems!

Well.. cooling fan sensor is not in any way the problem. It sits in the radiator, and how do you figure it would have anything with the stat not opening? Even if it would, the hot water could not reach it, because.. :wall: ..the stat is not opening so the water cant cirulate. :? The garage will chan...
by Flying Dutchman
Sun Dec 28, 2014 4:17 pm
Forum: Engine (20)
Topic: Overheating problems!
Replies: 8
Views: 1890

Re: Overheating problems!

Thanks guys! Unfortunatly I haven got it sorted yet. I returned the car to the garage, but they dont find anything wrong. It wont overheat, they say. But still, they changed the thermostat.. At least they claim. Took a "longer" trip and had to stop because it got overheated again. Its funny how it g...
by Flying Dutchman
Mon Dec 15, 2014 9:48 pm
Forum: Engine (20)
Topic: Overheating problems!
Replies: 8
Views: 1890

Re: Overheating problems!

Really dont know. Did not experience any problems before having the termo changed. Its supposed to be the 89 degrees celsius, but maybe the garage installed a different..
by Flying Dutchman
Mon Dec 15, 2014 9:07 pm
Forum: Engine (20)
Topic: Overheating problems!
Replies: 8
Views: 1890

Overheating problems!

Can the Thermostat get stuck? Every day the car gets overheated. I sometimes have to stop and let It cool down a couple of times, when going to work because the warning flashes "STOP" as the water temp rises to 115 degrees celsius. Sometimes the temperature suddenly drops to 80, (finally opens?) and...
by Flying Dutchman
Fri Nov 28, 2014 10:52 pm
Forum: Electrical system (30)
Topic: Heated seats
Replies: 2
Views: 1045

Heated seats

Guess what? My heated seats doesn't work. :wink:

I press the buttons and they lit, but no heat comes on. Is there a common fault to check, or how do I fix them?

Cheap n easy wouldn't hurt either. Thanks in advance! :)
by Flying Dutchman
Mon Nov 10, 2014 10:31 pm
Forum: Power transmission (40)
Topic: Car shacking when pushed
Replies: 5
Views: 2497

Re: Car shacking when pushed

I also think it's oil on the clutch. Had similar (but smaller) issues on my 1977 244. I sprayed Bräkleen on the clutch and that took the problems away for a while, but it came back due to leaking crank seals.
by Flying Dutchman
Sat Nov 08, 2014 9:30 am
Forum: Electrical system (30)
Topic: Hissing VEM!
Replies: 13
Views: 5033

Re: Hissing VEM!

Finally found it! The vacuum hose was blocked by the front mount of the container for windshield wash (hope you can understand my poor English) Had the car in a workshop changing timing belt. They must hav put the hose on the wrong side of it and just tighten the bolt.. So no VEM error here.